On Fri, 20 Dec 2019 07:56:07 -0800
Sean Christopherson [off-list ref] wrote:
On Fri, Dec 20, 2019 at 11:04:45AM +0100, Cornelia Huck wrote:
quoted
On Wed, 18 Dec 2019 13:55:20 -0800
Sean Christopherson [off-list ref] wrote:
quoted
Rename kvm_arch_vcpu_setup() to kvm_s390_vcpu_setup() and manually call
the new function during kvm_arch_vcpu_create(). Define an empty
kvm_arch_vcpu_setup() as it's still required for compilation. This
is effectively a nop as kvm_arch_vcpu_create() and kvm_arch_vcpu_setup()
are called back-to-back by common KVM code. Obsoleting
kvm_arch_vcpu_setup() paves the way for its removal.
Note, gmap_remove() is now called if setup fails, as s390 was previously
freeing it via kvm_arch_vcpu_destroy(), which is called by common KVM
code if kvm_arch_vcpu_setup() fails.
Yes, this looks like the only thing that needs to be undone
(sca_add_vcpu() is done later in the process.)
Maybe mention that gmap_remove() is for ucontrol only? I was confused
for a moment :)
Will do.
Would it also make sense to open code __kvm_ucontrol_vcpu_init() in a
separate patch immediately preceding this change? That'd make it a little
more obvious why gmap_remove() is called, and it would eliminate the
"uninit" verbiage in the label, e.g.:
I'm a bit undecided here; especially as I'm not sure if there are any
future plans with ucontrol. I'll leave that for Christian and Janosch
to decide.
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel