On Sat, Sep 7, 2019 at 5:28 PM Stephen Boyd [off-list ref] wrote:
Quoting Dong Aisheng (2019-08-20 04:13:18)
quoted
diff --git a/drivers/clk/imx/clk-scu.c b/drivers/clk/imx/clk-scu.c
index 48bfb08..5f935b1 100644
--- a/drivers/clk/imx/clk-scu.c
+++ b/drivers/clk/imx/clk-scu.c
@@ -479,6 +479,10 @@ static int imx_clk_scu_attach_pd(struct device *dev, u32 rsrc_id)
.args[0] = rsrc_id,
};
+ if ((rsrc_id == IMX_SC_R_A35) || (rsrc_id == IMX_SC_R_A53) ||
+ (rsrc_id == IMX_SC_R_A72))
Please drop the extra parenthesis. It makes it hard to read.
Will drop it, thx
Regards
Aisheng
quoted
+ return 0;
+
return of_genpd_add_device(&genpdspec, dev);
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel