Thread (44 messages) 44 messages, 2 authors, 2019-10-11

Re: [PATCH v3 04/17] arm64, hibernate: rename dst to page in create_safe_exec_page

flat view

From: Pavel Tatashin <pasha.tatashin@soleen.com>
Date: 2019-09-06 15:41:17
Also in: kexec, linux-mm, lkml

On Fri, Sep 6, 2019 at 11:17 AM James Morse [off-list ref] wrote:
Hi Pavel,

On 21/08/2019 19:31, Pavel Tatashin wrote:
quoted
create_safe_exec_page() allocates a safe page and maps it at a
specific location, also this function returns the physical address
of newly allocated page.

The destination VA, and PA are specified in arguments: dst_addr,
phys_dst_addr

However, within the function it uses "dst" which has unsigned long
type, but is actually a pointers in the current virtual space. This
is confusing to read.
The type? There are plenty of places in the kernel that an unsigned-long is actually a
pointer. This isn't unusual.

quoted
Rename dst to more appropriate page (page that is created), and also
change its time to "void *"
If you think its clearer,
Reviewed-by: James Morse <james.morse@arm.com>
Thank you for your review.

Pasha

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help