Thread (51 messages) 51 messages, 7 authors, 2019-08-19

Re: [RFC PATCH 03/11] devfreq: exynos-bus: Change goto-based logic to if-else logic

From: Krzysztof Kozlowski <krzk@kernel.org>
Date: 2019-07-24 19:10:13
Also in: dri-devel, linux-devicetree, linux-pm, linux-samsung-soc, lkml

On Tue, Jul 23, 2019 at 02:20:08PM +0200, Artur Świgoń wrote:
This patch improves code readability by changing the following construct:
quoted
   if (cond)
       goto passive;
   foo();
   goto out;
passive:
   bar();
out:
into this:
quoted
   if (cond)
       bar();
   else
       foo();
Signed-off-by: Artur Świgoń <redacted>
---
 drivers/devfreq/exynos-bus.c | 24 +++++++++---------------
 1 file changed, 9 insertions(+), 15 deletions(-)
Code looks much better:
Reviewed-by: Krzysztof Kozlowski <krzk@kernel.org>

Best regards,
Krzysztof

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help