Re: [PATCH v4 1/2] media: uapi: Add H264 low-level decoder API compound controls.
From: Maxime Ripard <hidden>
Date: 2019-03-05 09:43:46
Also in:
linux-media, lkml
Hi, On Mon, Mar 04, 2019 at 03:49:11PM -0300, Ezequiel Garcia wrote:
On Wed, 2019-02-20 at 15:17 +0100, Maxime Ripard wrote:quoted
From: Pawel Osciak <redacted> Stateless video codecs will require both the H264 metadata and slices in order to be able to decode frames. This introduces the definitions for a new pixel format for H264 slices that have been parsed, as well as the structures used to pass the metadata from the userspace to the kernel. Co-Developped-by: Maxime Ripard [off-list ref] Signed-off-by: Pawel Osciak <redacted> Signed-off-by: Guenter Roeck <groeck@chromium.org> Signed-off-by: Maxime Ripard <redacted> --- Documentation/media/uapi/v4l/biblio.rst | 9 +- Documentation/media/uapi/v4l/extended-controls.rst | 547 ++++++++++++++-It seems Hans splitted the documentation and so this should now go to Documentation/media/uapi/v4l/ext-ctrls-codec.rst.
Thanks for letting me know, it will be fixed in the next version.
quoted
+#define V4L2_PIX_FMT_H264_SLICE v4l2_fourcc('S', '2', '6', '4') /* H264 parsed slices */ #define V4L2_PIX_FMT_H263 v4l2_fourcc('H', '2', '6', '3') /* H263 */ #define V4L2_PIX_FMT_MPEG1 v4l2_fourcc('M', 'P', 'G', '1') /* MPEG-1 ES */ #define V4L2_PIX_FMT_MPEG2 v4l2_fourcc('M', 'P', 'G', '2') /* MPEG-2 ES */I haven't seen any objections to renaming this to V4L2_PIX_FMT_H264_SLICE_RAW, so if you could be so kind to push v5 with this rename (or similar), and also rebasing to the master branch, I could then submit the H264 decoder support for the Rockchip VPU.
I don't remember it, but yeah, this is fine by me. I'll adjust it and send a new version. Maxime -- Maxime Ripard, Bootlin Embedded Linux and Kernel engineering https://bootlin.com