Thread (13 messages) 13 messages, 5 authors, 2019-01-15

Re: [PATCH] mm: Introduce GFP_PGTABLE

flat view

From: Anshuman Khandual <hidden>
Date: 2019-01-14 04:01:07
Also in: kvmarm, linux-mm, linux-sh, linuxppc-dev, lkml


On 01/13/2019 11:05 PM, Michal Hocko wrote:
On Sat 12-01-19 15:56:38, Anshuman Khandual wrote:
quoted
All architectures have been defining their own PGALLOC_GFP as (GFP_KERNEL |
__GFP_ZERO) and using it for allocating page table pages. This causes some
code duplication which can be easily avoided. GFP_KERNEL allocated and
cleared out pages (__GFP_ZERO) are required for page tables on any given
architecture. This creates a new generic GFP flag flag which can be used
for any page table page allocation. Does not cause any functional change.
I agree that some unification is due but GFP_PGTABLE is not something to
expose in generic gfp.h IMHO. It just risks an abuse. I would be looking
Why would you think that it risks an abuse ? It does not create new semantics
of allocation in the buddy. Its just uses existing GFP_KERNEL allocation which
is then getting zeroed out. The risks (if any) is exactly same as GFP_KERNEL.
at providing asm-generic implementation and reuse it to remove the code
Does that mean GFP_PGTABLE can be created but not in gfp.h but in some other
memory related header file ?
duplication. But I haven't tried that to know that it will work out due
to small/subtle differences between arches.
IIUC from the allocation perspective GFP_ACCOUNT is the only thing which gets
added with GFP_PGTABLE for user page table for memcg accounting purpose. There
does not seem to be any other differences unless I am missing something.

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help