On Wed, 7 Nov 2018 10:38:59 -0700 Logan Gunthorpe [off-list ref] wrote:
quoted hunk ↗ jump to hunk
Presently the arches arm64, arm and sh have a function which loops through
each memblock and calls memory present. riscv will require a similar
function.
Introduce a common memblocks_present() function that can be used by
all the arches. Subsequent patches will cleanup the arches that
make use of this.
...
--- a/mm/sparse.c
+++ b/mm/sparse.c
@@ -239,6 +239,17 @@ void __init memory_present(int nid, unsigned long start, unsigned long end)
}
}
+void __init memblocks_present(void)
+{
+ struct memblock_region *reg;
+
+ for_each_memblock(memory, reg) {
+ memory_present(memblock_get_region_node(reg),
+ memblock_region_memory_base_pfn(reg),
+ memblock_region_memory_end_pfn(reg));
+ }
+}
+
I don't like the name much. To me, memblocks_present means "are
memblocks present" whereas this actually means "memblocks are present".
But whatever. A little covering comment which describes what this
does and why it does it would be nice.
Acked-by: Andrew Morton <akpm@linux-foundation.org>
I can grab both patches and shall sneak them into 4.20-rcX, but feel
free to merge them into some git tree if you'd prefer. If I see them
turn up in linux-next I shall drop my copy.