[PATCH 10/13] block: remove bvec_to_phys
From: geert@linux-m68k.org (Geert Uytterhoeven)
Date: 2018-09-04 19:36:06
Also in:
linux-block, xen-devel
From: geert@linux-m68k.org (Geert Uytterhoeven)
Date: 2018-09-04 19:36:06
Also in:
linux-block, xen-devel
On Tue, Sep 4, 2018 at 9:23 PM Christoph Hellwig [off-list ref] wrote:
We only use it in biovec_phys_mergeable and a m68k paravirt driver, so just opencode it there. Also remove the pointless unsigned long cast for the offset in the opencoded instances. Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Geert Uytterhoeven <geert@linux-m68k.org>
--- arch/m68k/emu/nfblock.c | 2 +-
Acked-by: Geert Uytterhoeven <geert@linux-m68k.org>
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert at linux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds