Thread (6 messages) flat view 6 messages, 3 authors, 2018-05-23
STALE3000d REVIEWED: 1 (0M)

Revision v1 of 2 in this series; 1 review trailer.

Revisions (2)
  1. v1 [diff vs current]
  2. v1 current

[PATCH 1/2] arm64: make is_permission_fault() name clearer

From: Will Deacon <hidden>
Date: 2018-05-22 17:06:32

On Mon, May 21, 2018 at 02:14:50PM +0100, Mark Rutland wrote:
The naming of is_permission_fault() makes it sound like it should return
true for permission faults from EL0, but by design, it only does so for
faults from EL1.

Let's make this clear by dropping el1 in the name, as we do for
is_el1_instruction_abort().

Signed-off-by: Mark Rutland <mark.rutland@arm.com>
Cc: Catalin Marinas <catalin.marinas@arm.com>
Cc: Will Deacon <redacted>
---
 arch/arm64/mm/fault.c | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
Acked-by: Will Deacon <redacted>

Will
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help