On Thu, Feb 15, 2018 at 10:03:26PM +0100, Christoffer Dall wrote:
To make the code more readable and to avoid the overhead of a function
call, let's get rid of a pair of the alternative function selectors and
explicitly call the VHE and non-VHE functions using the has_vhe() static
key based selector instead, telling the compiler to try to inline the
static function if it can.
Signed-off-by: Christoffer Dall <redacted>
---
arch/arm64/kvm/hyp/switch.c | 30 ++++++++++++++----------------
1 file changed, 14 insertions(+), 16 deletions(-)
Reviewed-by: Andrew Jones <redacted>