Thread (1 message) 1 message, 1 author, 2018-01-24
DORMANTno replies

[PATCH 1/5] drm: rename {drm_clflush_sg, drm_clflush_pages}

From: Chris Wilson <hidden>
Date: 2018-01-24 18:53:48
Also in: dri-devel

Quoting Gurchetan Singh (2018-01-24 18:45:07)
On Wed, Jan 24, 2018 at 1:14 AM, Chris Wilson [off-list ref] wrote:

    Quoting Gurchetan Singh (2018-01-24 02:55:30)
    > Since clfush is an x86-only instruction, these function names won't
    > make much sense if we start adding cases for other architectures.

    Whatever your dislike for the name, it has one clear advantage over the
    new one: it tells you what it is flushing.
    -Chris


What do you suggest, if one wants to flush vgem pages on ARM architecture??
Should we have a drm_clflush_pages(..) and a drm_arm_flush_pages(..), separated
by #ifdef statements?
drm_cachelines_flush_pages, drm_clflush_pages for short.
Or drm_dcache_flush_pages.
-Chris
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help