[PATCH 11/12] ARM: dts: imx6qdl-nitrogen6_max: Remove unneeded unit address
From: festevam@gmail.com (Fabio Estevam)
Date: 2017-12-04 11:28:08
Also in:
linux-devicetree
Hi Gary, On Mon, Dec 4, 2017 at 9:19 AM, Gary Bisson [off-list ref] wrote:
What about naming it i2c2mux and i2c3mux so it is clearer those mux happen respectively for i2c2 and i2c3? Then I'd rename the sub-nodes i2cXmux at Y instead of i2cX at Y currently. Let me know your thoughts.
Is this what you suggest?
--- a/arch/arm/boot/dts/imx6qdl-nitrogen6_max.dtsi
+++ b/arch/arm/boot/dts/imx6qdl-nitrogen6_max.dtsi@@ -172,7 +172,7 @@ }; }; - i2cmux at 2 { + i2c2mux { compatible = "i2c-mux-gpio"; pinctrl-names = "default"; pinctrl-0 = <&pinctrl_i2c2mux>;
@@ -183,20 +183,20 @@ i2c-parent = <&i2c2>; idle-state = <0>; - i2c2 at 1 { + i2c2mux at 1 { reg = <1>; #address-cells = <1>; #size-cells = <0>; }; - i2c2 at 2 { + i2c2mux at 2 { reg = <2>; #address-cells = <1>; #size-cells = <0>; }; }; - i2cmux at 3 { + i2c3mux { compatible = "i2c-mux-gpio"; pinctrl-names = "default"; pinctrl-0 = <&pinctrl_i2c3mux>;
@@ -206,7 +206,7 @@ i2c-parent = <&i2c3>; idle-state = <0>; - i2c3 at 1 { + i2c3mux at 1 { reg = <1>; #address-cells = <1>; #size-cells = <0>;