[PATCH v2 1/5] dt-bindings: rtc: add bindings for i.MX53 SRTC
From: robh@kernel.org (Rob Herring)
Date: 2017-12-15 21:58:32
Also in:
linux-devicetree, linux-rtc, lkml
On Mon, Dec 11, 2017 at 1:08 AM, Patrick Br?nn [off-list ref] wrote:
quoted
From: Rob Herring [mailto:robh at kernel.org] Sent: Mittwoch, 6. Dezember 2017 22:55 On Tue, Dec 05, 2017 at 03:06:42PM +0100, linux-kernel-dev at beckhoff.com wrote:quoted
From: Patrick Bruenn <redacted>+++ b/Documentation/devicetree/bindings/rtc/rtc-mxc_v2.txt@@ -0,0 +1,17 @@ +* i.MX53 Real Time Clock controller + +Required properties: +- compatible: should be: "fsl,imx53-rtc" +- reg: physical base address of the controller and length of memorymappedquoted
+ region. +- clocks: should contain the phandle for the rtc clockShouldn't there be more than 1 here. From what I remember, the ipg clock and the 32k clock?Yes, you are right. But if I am reading the original Freescale driver and the reference manual correctly, the second clock is always active. Section "72.3.1.1 Clocks" from the reference manual [1] reads: "SRTC runs on two clock sources, high frequency peripherals clock and low frequency timers clock. The high frequency peripheral IP clock is used by the SRTC peripheral bus interface, control and status registers. The low frequency 32.768 kHz clock is the always-active clock used by the SRTC timers..." That's why I would only include one clock . Should I change this?
Some chips supported 32.0kHz and 32.768kHz low freq clocks, so you'd need to be able to query what the frequency is even if you don't need to enable the clock, but maybe that may be gone in MX53. I don't remember.
quoted
quoted
+- interrupts: rtc alarm interrupt + +Example: + +srtc at 53fa4000 {rtc at ...The rtc for which this series adds support is embedded within a function block called "Secure Real Time Clock". This driver doesn't utilize all of the hardware features by now. But maybe someone else wants to extend the functionalities, later. For that possibility I wanted to name the node "srtc". Should I still change this? I believe you have a much better understanding of what should be done here. I don't want to argue with you, just thought you might not had that information. So if I am wrong just tell me and I will change it without further "complaining".
Node names should be generic for the class of h/w they are. So yes, it should be "rtc". Rob