Thread (34 messages) 34 messages, 5 authors, 2017-05-15

[PATCH V8 2/5] PCI/ASPM: split pci_aspm_init() into two

From: bhelgaas@google.com (Bjorn Helgaas)
Date: 2017-04-13 18:26:12
Also in: linux-arm-msm, linux-pci, lkml

On Wed, Apr 12, 2017 at 2:16 PM, Rajat Jain [off-list ref] wrote:
On Fri, Apr 7, 2017 at 9:55 PM, Sinan Kaya [off-list ref] wrote:
quoted
Split pci_aspm_init() body into pci_aspm_init_upstream()
and pci_aspm_init_downstream() for bridge and endpoint
specific code behavior.

Fixes: https://bugzilla.kernel.org/show_bug.cgi?id=194895
Signed-off-by: Sinan Kaya <redacted>
---
 drivers/pci/pcie/aspm.c | 15 ++++++++++++++-
 1 file changed, 14 insertions(+), 1 deletion(-)
diff --git a/drivers/pci/pcie/aspm.c b/drivers/pci/pcie/aspm.c
index dc36717..a80d64b 100644
--- a/drivers/pci/pcie/aspm.c
+++ b/drivers/pci/pcie/aspm.c
@@ -826,6 +826,16 @@ static struct pcie_link_state *alloc_pcie_link_state(struct pci_dev *pdev)
        return link;
 }

+static int pci_aspm_init_downstream(struct pci_dev *pdev)
+{
+       return 0;
+}
+
+static int pci_aspm_init_upstream(struct pci_dev *pdev)
+{
+       return 0;
+}
+
 /*
  * pci_aspm_init: Initiate PCI express link state.
  * It is called from device_add for every single pci device.
@@ -833,7 +843,10 @@ static struct pcie_link_state *alloc_pcie_link_state(struct pci_dev *pdev)
  */
 int pci_aspm_init(struct pci_dev *pdev)
 {
-       return 0;
+       if (!pdev->has_secondary_link)
+               return pci_aspm_init_downstream(pdev);
+
+       return pci_aspm_init_upstream(pdev);
 }
Nit:

if (x_flag())
   return x();
return y();

May be better than

if (!x_flag)
    return y();
return x();
I agree, and I made that change on my branch.  I also renamed these to
pci_aspm_init_downstream_port() (for Root Ports and Switch Downstream
Ports) and pci_aspm_init_upstream_port() (for Switch Upstream Ports
and Endpoints) to try to match the terminology in the spec.

FWIW, your email didn't seem to make it to the list, Rajat.  Maybe
some gmail weirdness?  I don't *see* anything wrong, but ...  I'm
responding via gmail, so my response probably won't make it to the
list either.

Bjorn
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help