Thread (20 messages) flat view 20 messages, 4 authors, 2017-01-18

[PATCH net-next v4 05/10] drivers: base: Add device_find_in_class_name()

From: f.fainelli@gmail.com (Florian Fainelli)
Date: 2017-01-17 23:50:17
Also in: lkml, netdev

On 01/17/2017 03:34 PM, Andy Shevchenko wrote:
On Wed, Jan 18, 2017 at 1:21 AM, Florian Fainelli [off-list ref] wrote:
quoted
Add a helper function to lookup a device reference given a class name.
This is a preliminary patch to remove adhoc code from net/dsa/dsa.c and
make it more generic.
quoted
+static int device_class_name_match(struct device *dev, void *class)
And why not const char *class?
This was raised back in v2, and the same response applies:

https://www.mail-archive.com/netdev at vger.kernel.org/msg147559.html

Changing the signature of a callback is out of the scope of this patch
series.
-- 
Florian
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help