[RFC 6/6] ARM: dts: am57xx-beagle-x15-common: enable etnaviv
From: Robert Nelson <hidden>
Date: 2016-11-18 03:44:44
Also in:
linux-devicetree, linux-omap
On Thu, Nov 17, 2016 at 8:56 PM, Nishanth Menon [off-list ref] wrote:
On 11/17/2016 08:44 PM, Robert Nelson wrote: again.. a short commit message at least please? :)
yeah, i'll fix all those. ;)
quoted
Signed-off-by: Robert Nelson <redacted> CC: Julien <redacted> CC: Nishanth Menon <nm@ti.com> CC: Tomi Valkeinen <redacted> CC: Tony Lindgren <tony@atomide.com> --- arch/arm/boot/dts/am57xx-beagle-x15-common.dtsi | 11 +++++++++++ 1 file changed, 11 insertions(+)diff --git a/arch/arm/boot/dts/am57xx-beagle-x15-common.dtsib/arch/arm/boot/dts/am57xx-beagle-x15-common.dtsi index 6df7829..3bc47be 100644--- a/arch/arm/boot/dts/am57xx-beagle-x15-common.dtsi +++ b/arch/arm/boot/dts/am57xx-beagle-x15-common.dtsi@@ -97,6 +97,12 @@ #cooling-cells = <2>; }; + gpu-subsystem {A) do we want to make things clear that this is gpu subsystem for gc320? B) How about other platforms that could equally reuse?
so the 'gpu-subsystem' comes from etnaviv: https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/tree/Documentation/devicetree/bindings/display/etnaviv/etnaviv-drm.txt?id=refs/tags/v4.9-rc5 For a generic name, it's currently only tied to the etnaviv driver: gpu-subsystem { compatible = "fsl,imx-gpu-subsystem"; cores = <&gpu_2d>, <&gpu_3d>; }; it would make sense to make that more generic, so you could tie a 2d vivante and a imgtec/sgx 3d core.. <sad laugh> but that would require adding a imgtec/sgx driver/bindings to the kernel mainline... </sad laugh>
quoted
+ compatible = "ti,gc320-gpu-subsystem"; + cores = <&bb2d>; + status = "okay"; + }; + hdmi0: connector { compatible = "hdmi-connector"; label = "hdmi";@@ -190,6 +196,11 @@ >; }; }; + +&bb2d { + status = "okay"; +}; + &i2c1 { status = "okay"; clock-frequency = <400000>;
Regards, -- Robert Nelson https://rcn-ee.com/