[PATCHv3 5/6] arm64: Use __pa_symbol for kernel symbols
From: mark.rutland@arm.com (Mark Rutland)
Date: 2016-11-23 09:57:45
Also in:
linux-mm, lkml
From: mark.rutland@arm.com (Mark Rutland)
Date: 2016-11-23 09:57:45
Also in:
linux-mm, lkml
On Mon, Nov 21, 2016 at 09:40:06AM -0800, Laura Abbott wrote:
On 11/18/2016 06:35 AM, Mark Rutland wrote:quoted
On Thu, Nov 17, 2016 at 05:16:55PM -0800, Laura Abbott wrote:quoted
/* Grab the vDSO code pages. */ for (i = 0; i < vdso_pages; i++) - vdso_pagelist[i + 1] = pfn_to_page(PHYS_PFN(__pa(&vdso_start)) + i); + vdso_pagelist[i + 1] = pfn_to_page(PHYS_PFN(__pa_symbol(&vdso_start)) + i);Nit: phys_to_page() again.I think it makes sense to keep this one as is. It's offsetting by pfn number and trying force phys_to_page would make it more difficult to read.
My bad; I failed to spot the + i. That sounds good to me; sorry for the noise there. Thanks, Mark.