Thread (21 messages) flat view 21 messages, 6 authors, 2016-12-07

Synopsys Ethernet QoS Driver

From: Joao Pinto <hidden>
Date: 2016-11-22 14:17:06
Also in: lkml, netdev

Hi Lars and Peppe,

On 21-11-2016 16:11, Joao Pinto wrote:
On 21-11-2016 15:43, Lars Persson wrote:
quoted
quoted
21 nov. 2016 kl. 16:06 skrev Joao Pinto [off-list ref]:
quoted
On 21-11-2016 14:25, Giuseppe CAVALLARO wrote:
quoted
On 11/21/2016 2:28 PM, Lars Persson wrote:

quoted
21 nov. 2016 kl. 13:53 skrev Giuseppe CAVALLARO [off-list ref]:

Hello Joao
quoted
On 11/21/2016 1:32 PM, Joao Pinto wrote:
Hello,
quoted
quoted
On 21-11-2016 05:29, Rayagond Kokatanur wrote:
quoted
On Sat, Nov 19, 2016 at 7:26 PM, Rabin Vincent [off-list ref] wrote:
On Fri, Nov 18, 2016 at 02:20:27PM +0000, Joao Pinto wrote:
For now we are interesting in improving the synopsys QoS driver under
/nect/ethernet/synopsys. For now the driver structure consists of a
single file
called dwc_eth_qos.c, containing synopsys ethernet qos common ops and
snip (...)
quoted
quoted
quoted
quoted
quoted
Peppe
Hello Joao and others,
Hi Lars,
quoted
quoted
As the maintainer of dwc_eth_qos.c I prefer also that we put efforts on the
most mature driver, the stmmac.

I hope that the code can migrate into an ethernet/synopsys folder to keep the
convention of naming the folder after the vendor. This makes it easy for
others to find the driver.

The dwc_eth_qos.c will eventually be removed and its DT binding interface can
then be implemented in the stmmac driver.
So your ideia is to pick the ethernet/stmmac and rename it to ethernet/synopsys
and try to improve the structure and add the missing QoS features to it?
Indeed this is what I prefer.
Ok, it makes sense.
Just for curiosity the target setup is the following:
https://www.youtube.com/watch?v=8V-LB5y2Cos
but instead of using internal drivers, we desire to use mainline drivers only.

Thanks!
Regarding this subject, I am thinking of making the following adaption:

a) delete ethernet/synopsys
b) rename ethernet/stmicro/stmmac to ethernet/synopsys

and send you a patch for you to evaluate. Both agree with the approach?
To have a new work base would be important, because I will add to the "new"
structure some missing QoS features like Multichannel support, CBS and later TSN.

Thanks.
quoted
quoted
quoted
Thanks Lars, I will be happy to support all you on this transition
and I agree on renaming all.

peppe

quoted
- Lars
quoted
quoted
quoted
quoted
(See http://lists.openwall.net/netdev/2016/02/29/127)

The former only supports 4.x of the hardware.

The later supports 4.x and 3.x and already has a platform glue driver
with support for several platforms, a PCI glue driver, and a core driver
with several features not present in the former (for example: TX/RX
interrupt coalescing, EEE, PTP).

Have you evaluated both drivers?  Why have you decided to work on the
former rather than the latter?
Thanks.


Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help