[RFC 1/5] powerpc: Rename context.vdso_base to context.vdso
From: bsingharora@gmail.com (Balbir Singh)
Date: 2016-05-02 01:05:55
Also in:
linux-arch, linux-mm, linuxppc-dev, lkml
From: bsingharora@gmail.com (Balbir Singh)
Date: 2016-05-02 01:05:55
Also in:
linux-arch, linux-mm, linuxppc-dev, lkml
On 29/04/16 01:18, Christopher Covington wrote:
In order to share remap and unmap support for the VDSO with other architectures without duplicating the code, we need a common name and type for the address of the VDSO. An informal survey of the architectures indicates unsigned long vdso is popular. Change the variable name in powerpc from mm->context.vdso_base to simply mm->context.vdso.
Could you please provide additional details on why the remap/unmap operations are required? This patch does rename, but should it abstract via a function acesss to vmap field using arch_* operations? Not sure Balbir Singh