[PATCH 18/27] mtd: nand: update mtd_to_nand()
From: Boris Brezillon <hidden>
Date: 2015-11-17 08:26:29
Also in:
linux-omap, linux-samsung-soc, lkml
On Mon, 16 Nov 2015 19:03:53 -0800 Brian Norris [off-list ref] wrote:
On Mon, Nov 16, 2015 at 02:37:51PM +0100, Boris Brezillon wrote:quoted
Now that all drivers are using the mtd instance embedded in the nand_chipDo you have a script that verifies this? I thought you did at some point, and it'd be nice to note it, so I can also use it to verify things once it gets applied.
No, didn't write that script, but it should probably look like the one I used to remove the mtd field from driver private struct.
quoted
struct we can safely update the mtd_to_nand_chip() implementation to useNit: s/mtd_to_nand_chip/mtd_to_nand/
Yep, I'll fix that.
quoted
the container_of macro instead of returning the content of mtd->priv. This will allow us to remove mtd->priv = chip assignments done in all NAND controller drivers. Signed-off-by: Boris Brezillon <redacted> --- include/linux/mtd/nand.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)diff --git a/include/linux/mtd/nand.h b/include/linux/mtd/nand.h index 8ec071e..873646d 100644 --- a/include/linux/mtd/nand.h +++ b/include/linux/mtd/nand.h@@ -734,7 +734,7 @@ static inline struct device_node *nand_get_flash_node(struct nand_chip *chip) static inline struct nand_chip *mtd_to_nand(struct mtd_info *mtd) { - return mtd->priv; + return container_of(mtd, struct nand_chip, mtd); } static inline struct mtd_info *nand_to_mtd(struct nand_chip *chip)-- 2.1.4
-- Boris Brezillon, Free Electrons Embedded Linux and Kernel engineering http://free-electrons.com