On Tue, 2015-09-08 at 12:18 -0300, Ezequiel Garcia wrote:
On 8 September 2015 at 08:53, Jagan Teki [off-list ref] wrote:
quoted
On 8 September 2015 at 15:19, Bayi Cheng [off-list ref] wrote:
quoted
Add Mediatek nor flash node
Signed-off-by: Bayi Cheng <redacted>
---
arch/arm64/boot/dts/mediatek/mt8173.dtsi | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/arch/arm64/boot/dts/mediatek/mt8173.dtsi b/arch/arm64/boot/dts/mediatek/mt8173.dtsi
index d18ee42..a14f005 100644
--- a/arch/arm64/boot/dts/mediatek/mt8173.dtsi
+++ b/arch/arm64/boot/dts/mediatek/mt8173.dtsi
@@ -365,6 +365,16 @@
status = "disabled";
};
+ nor_flash: nor at 1100d000 {
Based on the comments from 1/3 - this notation needs to be change something like
qspi0: quadspi at 1100d000
Actually, to follow ePAPR recomendations it should be named as flash at 1100d000.
(See ePAPR, 2.2.2 Generic Names Recommendation).
I believe the phandle name choice can be more descriptive.
Thanks for your instruct, I will fix it in the next patch !