Thread (1 message) 1 message, 1 author, 2015-09-08

[PATCH v2 1/9] ARM: dts: imx6dql-nitrogen6x: add touchscreen support

From: Russell King - ARM Linux <hidden>
Date: 2015-09-08 20:33:57
Also in: linux-devicetree

On Tue, Sep 08, 2015 at 04:49:20PM +0200, Philipp Zabel wrote:
Am Dienstag, den 08.09.2015, 16:34 +0200 schrieb Gary Bisson:
quoted
This patch adds the different touchscreens that can be connected using
the displays available for this board.
http://boundarydevices.com/product-category/displays/

Signed-off-by: Gary Bisson <redacted>
---
 arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
diff --git a/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi b/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi
index ad16dce..24b667d 100644
--- a/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi
+++ b/arch/arm/boot/dts/imx6qdl-nitrogen6x.dtsi
@@ -284,6 +284,22 @@
 	pinctrl-names = "default";
 	pinctrl-0 = <&pinctrl_i2c3>;
 	status = "okay";
+
+	egalax_ts at 04 {
I'd prefer to use generic names for the nodes, such as "touchscreen at 04",
and "touchscreen at 38" below.
ePAPR actually says that the node name should be the general class of
the device, and recommending that it should be generic:

2.2.1.1 Node Name Requirements
...
The node-name shall start with a lower or uppercase character and should
describe the general class of device.

2.2.2 Generic Names Recommendation
The name of a node should be somewhat generic, reflecting the function of
the device and not its precise programming model. If appropriate, the name
should be one of the following choices: ...

It would be nice if more bindings followed this.

-- 
FTTC broadband for 0.8mile line: currently at 9.6Mbps down 400kbps up
according to speedtest.net.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help