Thread (1 message) 1 message, 1 author, 2015-08-11

[PATCH v6 0/6] PCI: hisi: Add PCIe host support for HiSilicon SoC Hip05

From: Gabriele Paoloni <hidden>
Date: 2015-08-11 07:39:16
Also in: linux-devicetree, linux-pci

Hi Bjorn and all

Any comment on this patchset?

Thanks

Gab
-----Original Message-----
From: Wangzhou (B)
Sent: Friday, August 07, 2015 7:01 AM
To: Wangzhou (B)
Cc: Bjorn Helgaas; Jingoo Han; Pratyush Anand; Arnd Bergmann;
linux at arm.linux.org.uk; thomas.petazzoni at free-electrons.com; Gabriele
Paoloni; lorenzo.pieralisi at arm.com; James Morse; Liviu.Dudau at arm.com;
Jason Cooper; robh at kernel.org; linux-pci at vger.kernel.org; linux-arm-
kernel at lists.infradead.org; devicetree at vger.kernel.org; Yuanzhichang;
Zhudacai; zhangjukuo; qiuzhenfa; liudongdong (C); qiujiang;
Kangfenglong; xuwei (O); Liguozhu (Kenneth)
Subject: Re: [PATCH v6 0/6] PCI: hisi: Add PCIe host support for
HiSilicon SoC Hip05

[+cc jingoohan1 at gmail.com]

On 2015/8/6 16:09, Zhou Wang wrote:
quoted
This patchset adds PCIe host support for HiSilicon SoC Hip05. The
PCIe hosts
quoted
use PCIe IP core from Synopsys, So this driver is base on designware
PCIe driver.
quoted
Hip05 is an ARMv8 architecture SoC. It should be able to use ARM64
PCIe API in
quoted
designeware PCIe driver. So this patch also adds ARM64 support for
designware
quoted
pcie.

This patchset is based on v4.2-rc1.

Change from v5:
- Merge 1/6 in this series, discussion about this can be found in [1]

Change from v4:
- Change the author of 1/5 to Gabriele.
- Modify problems in 3/5 pointed by Bjorn.
- Modify spelling problems in 4/5.

Change from v3:
- Change 1/5 to what Gabriele suggested.
- Use win->__res.start to get *_mod_base in 2/5, this fix a bug in v3
series.
quoted
Change from v2:
- Move struct pci_dev *dev and struct pci_sys_data *sys in
  pcibios_align_resource in 1/5.
- Add Gabriele's codes in 2/5 which delete unnecessary information
parse and
quoted
  use of_pci_get_host_bridge_resources for both ARM32 and ARM64.
- Add maintainer patch 5/5.

Change from RFC v1:
- Add 1/4 patch by Arnd which removes align_resource callback in ARM
  pcibios_align_resource.
- Change head file in pcie-designware from asm/hardirq.h to
linux/hardirq.h.
quoted
- Set pp->root_bus_nr = 0 in dra7xx, exynos, imx6, keystone,
layerscape,
quoted
  spear13xx.
- Remove unnecessary parentheses of some macros in pcie-hisi.
- Use macro to replace some magic values.
- Merge two loops together and add some comments about it in
context_config
quoted
  function in pcie-hisi.
- Modify some value of items in pcie node example in binding document.

Change from RFC:
- delete dw_pcie_setup, dw_pcie_scan_bus, dw_pcie_map_irq and struct
hw_pci,
quoted
  merge related operations into dw_pcie_host_init.

Link of v5:
- http://www.spinics.net/lists/devicetree/msg87959.html
Link of v4:
- http://www.spinics.net/lists/arm-kernel/msg433050.html
Link of v3:
- http://www.spinics.net/lists/linux-pci/msg42539.html
Link of v2:
- http://www.spinics.net/lists/linux-pci/msg41844.html
Link of RFC v1:
- http://www.spinics.net/lists/linux-pci/msg41305.html
Link of RFC:
- http://www.spinics.net/lists/linux-pci/msg40434.html

[1] http://lists.infradead.org/pipermail/linux-arm-kernel/2015-
July/359741.html
quoted
Zhou Wang (4):
  PCI: designware: Add ARM64 support
  PCI: hisi: Add PCIe host support for HiSilicon SoC Hip05
  Documentation: DT: Add HiSilicon PCIe host binding
  MAINTAINERS: Add pcie-hisi maintainer

gabriele paoloni (2):
  PCI: designware: move calculation of bus addresses to DRA7xx
  ARM/PCI: remove align_resource in pci_sys_data

 .../devicetree/bindings/pci/hisilicon-pcie.txt     |  46 ++++
 MAINTAINERS                                        |   7 +
 arch/arm/include/asm/mach/pci.h                    |   5 -
 arch/arm/kernel/bios32.c                           |  12 +-
 drivers/pci/host/Kconfig                           |   8 +
 drivers/pci/host/Makefile                          |   1 +
 drivers/pci/host/pci-dra7xx.c                      |  14 ++
 drivers/pci/host/pci-exynos.c                      |   2 +-
 drivers/pci/host/pci-imx6.c                        |   2 +-
 drivers/pci/host/pci-keystone-dw.c                 |   2 +-
 drivers/pci/host/pci-keystone.c                    |   2 +-
 drivers/pci/host/pci-layerscape.c                  |   2 +-
 drivers/pci/host/pcie-designware.c                 | 236 ++++++-----
--------
quoted
 drivers/pci/host/pcie-designware.h                 |  14 +-
 drivers/pci/host/pcie-hisi.c                       | 254
+++++++++++++++++++++
quoted
 drivers/pci/host/pcie-spear13xx.c                  |   2 +-
 16 files changed, 425 insertions(+), 184 deletions(-)
 create mode 100644 Documentation/devicetree/bindings/pci/hisilicon-
pcie.txt
quoted
 create mode 100644 drivers/pci/host/pcie-hisi.c
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help