[RFC PATCH] EDAC: Cleanup atomic_scrub mess
From: bp@alien8.de (Borislav Petkov)
Date: 2015-05-27 15:52:19
Also in:
linux-devicetree
On Fri, May 22, 2015 at 04:13:22PM -0400, Chris Metcalf wrote:
On 05/21/2015 02:11 PM, Borislav Petkov wrote:quoted
From: Borislav Petkov<redacted> So first of all, this atomic_scrub() function's naming is bad. It looks like an atomic_t helper. Change it to edac_atomic_scrub(). The bigger problem is that this function is arch-specific and every new arch which doesn't necessarily need that functionality still needs to define it, otherwise EDAC doesn't compile. So instead of doing that and including arch-specific headers, have each arch define an EDAC_ATOMIC_SCRUB symbol which can be used in edac_mc.c for ifdeffery. Much cleaner. We already are doing this with another symbol - EDAC_SUPPORT. This is also much cleaner than having CONFIG_EDAC explicitly depend on all the arches which need/have EDAC support and drivers. This way I can kill the useless edac.h header in tile too. Signed-off-by: Borislav Petkov<redacted>Acked-by: Chris Metcalf <redacted> [for tile]
Thanks.
Just to clarify after today's discussion on IRC: this patch doesn't
change current DRAM scrubbing behavior on the relevant arches - it
simply makes the definition of that atomic_scrub thing non-mandatory on
new arches or on those which don't need it.
In the meantime, patch has been build-tested on arm and ppc - the two
I'm missing an ACK for.
:-)
--
Regards/Gruss,
Boris.
ECO tip #101: Trim your mails when you reply.
--