Thread (17 messages) 17 messages, 4 authors, 2015-05-26

[PATCH V5 2/3] OPP: Allow multiple OPP tables to be passed via DT

From: viresh.kumar@linaro.org (Viresh Kumar)
Date: 2015-05-26 04:51:24
Also in: linux-devicetree, linux-pm

On 21-05-15, 00:34, Nishanth Menon wrote:
quoted
+	cpu0_opp0: opp0 {
Maybe we should rename these as cpu0_opp_table_slow opp_table-fast
quoted
+		compatible = "operating-points-v2";
+		opp-name = "opp-slow";
just name = "slow" ?
quoted
+		opp-shared;
+
+		entry00 {
rename these as opp0, opp01 etc?
these are the actual OPP description, while, what we call "cpu0_opp0" is
actually an OPP table choice we have.
What about this now:
+Example 5: Multiple OPP tables
+
+/ {
+       cpus {
+               cpu at 0 {
+                       compatible = "arm,cortex-a7";
+                       ...
+
+                       opp-supply = <&cpu_supply>
+                       operating-points-v2 = <&cpu0_opp_table_slow>, <&cpu0_opp_table_fast>;
+               };
+       };
+
+       cpu0_opp_table_slow: opp_table_slow {
+               compatible = "operating-points-v2";
+               opp-name = "slow";
+               opp-shared;
+
+               opp00 {
+                       opp-hz = <600000000>;
+                       ...
+               };
+
+               opp01 {
+                       opp-hz = <800000000>;
+                       ...
+               };
+       };
+
+       cpu0_opp_table_fast: opp_table_fast {
+               compatible = "operating-points-v2";
+               opp-name = "fast";
+               opp-shared;
+
+               opp10 {
+                       opp-hz = <1000000000>;
+                       ...
+               };
+
+               opp11 {
+                       opp-hz = <1100000000>;
+                       ...
+               };
+       };
+};

May I carry your Ack or you want to give it again?

-- 
viresh
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help