Thread (30 messages) 30 messages, 4 authors, 2015-06-19

[PATCH 03/11] irqchip / GIC: Add GIC version support in ACPI MADT

From: Thomas Gleixner <hidden>
Date: 2015-05-21 14:39:29
Also in: linux-acpi, lkml

On Thu, 21 May 2015, Hanjun Guo wrote:
On 2015?05?21? 04:02, Thomas Gleixner wrote:
quoted
On Mon, 18 May 2015, Hanjun Guo wrote:
quoted
diff --git a/drivers/acpi/irq.c b/drivers/acpi/irq.c
index 65d6b93..855ead9 100644
--- a/drivers/acpi/irq.c
+++ b/drivers/acpi/irq.c
@@ -32,6 +32,9 @@ void __init acpi_irqchip_init(void)
  	if (acpi_disabled)
  		return;

+	if (acpi_gic_version_init())
+		return;
This looks just wrong. acpi_irqchip_init() is a generic ACPI function
and now you stick a GIC specific callback into it?
For now, acpi_irqchip_init() just introduced for GIC init, not for
APIC init for x86, and I don't see the usage in the near future.
quoted
What calls acpi_irqchip_init?
I renamed it as acpi_irq_init() in the later patch, which
is called in irqchip_init() in drivers/irqchip/irqchip.c
to init irqchip when DT is not available.
Neither of those names is a good choice as they suggest that this is a
generic acpi mechanism while in fact it is a GIC specific ACPI
extension. And its therefor wrong to put that code into drivers/acpi.

It belongs into drivers/irqchip/gic-acpi.c or some other descriptive
name.

Thanks,

	tglx
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help