Thread (13 messages) flat view 13 messages, 3 authors, 2015-03-24

[PATCH v2] ring-buffer: Replace this_cpu_*() with __this_cpu_*()

From: rostedt@goodmis.org (Steven Rostedt)
Date: 2015-03-17 15:07:54
Also in: lkml

On Tue, 17 Mar 2015 15:47:01 +0100
Uwe Kleine-K?nig [off-list ref] wrote:
Guten Morgen Steven,

On Tue, Mar 17, 2015 at 10:40:38AM -0400, Steven Rostedt wrote:
quoted
 static __always_inline void trace_recursive_unlock(void)
 {
-	unsigned int val = this_cpu_read(current_context);
+	unsigned int val = __this_cpu_read(current_context);
+	unsigned int val2;
 
-	val--;
-	val &= this_cpu_read(current_context);
-	this_cpu_write(current_context, val);
+	val2 = val - 1;
+	val &= val2;
+	__this_cpu_write(current_context, val);
You could use:

	unsigned int val = __this_cpu_read(current_context);

	val = val & (val - 1);

	__this_cpu_write(current_context, val);

and save a few lines and still make it more readable (IMHO).
Me too. My version came from looking at too much assembly, and val2
just happened to be another register in my mind.
BTW, this patch makes the additional lines in the trace disappear, so if
you think that makes a Tested-by applicable, feel free to add it.
OK, will do. Thanks.

Christoph, you happy with this version?

-- Steve
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help