Thread (19 messages) read the whole thread 19 messages, 3 authors, 2015-02-10

[PATCH 2/9] regulator: core: Introduce set_optimum_mode op

From: broonie@kernel.org (Mark Brown)
Date: 2015-01-29 01:25:36
Also in: linux-arm-msm, lkml

On Tue, Jan 27, 2015 at 06:46:32PM -0800, Bjorn Andersson wrote:
+	/* set most efficient regulator operating mode for load */
+	int (*set_optimum_mode)(struct regulator_dev *, int input_uV,
+				int output_uV, int load_uA);
This is basically fine but can you please rename this to be something
that more directly reflects the fact that we're just informing the
driver about the operating parameters - there are other things a driver
could usefully do with this, for example set current limits so that if
something starts to consume excessive current the device will flag this
as an error.

It'd also be better to split the voltage specs out into a separate
function, especially for the output voltage where obviously we have a
separate range based interface for setting that.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: Digital signature
URL: <http://lists.infradead.org/pipermail/linux-arm-kernel/attachments/20150128/534b8c8f/attachment.sig>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help