Thread (1 message) 1 message, 1 author, 2014-11-06

[PATCHv3 1/5] arm64: Add support for hooks to handle undefined instructions

From: Punit Agrawal <hidden>
Date: 2014-11-06 12:20:34

Catalin Marinas [off-list ref] writes:
On Mon, Oct 27, 2014 at 06:40:02PM +0000, Punit Agrawal wrote:
quoted
--- a/arch/arm64/include/asm/insn.h
+++ b/arch/arm64/include/asm/insn.h
@@ -354,6 +354,8 @@ bool aarch64_insn_hotpatch_safe(u32 old_insn, u32 new_insn);
 int aarch64_insn_patch_text_nosync(void *addr, u32 insn);
 int aarch64_insn_patch_text_sync(void *addrs[], u32 insns[], int cnt);
 int aarch64_insn_patch_text(void *addrs[], u32 insns[], int cnt);
+
+bool aarch32_insn_is_wide_instruction(u32 insn);
Nitpick: too wide function name ;). Maybe aarch32_insn_is_wide().
Agreed. I'll change it to aarch32_insn_is_wide(). Please shout if you
can think of a better name.
Otherwise the patch looks fine.

Reviewed-by: Catalin Marinas <catalin.marinas@arm.com>
Thanks.
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel at lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help