On Wednesday 01 October 2014 07:24:19 Ezequiel Garcia wrote:
quoted
config MTD_NAND_OMAP_BCH_BUILD
def_tristate MTD_NAND_OMAP2 && MTD_NAND_OMAP_BCH
which makes it 'm' if MTD_NAND_OMAP_BCH is set to m.
Just to clarify, you are talking about this one being the correct one,
right?
http://article.gmane.org/gmane.linux.ports.arm.omap/118488
"[PATCH 3/3] mtd: nand: Force omap_elm to be built as a module if omap2_nand is a module"
Yes. The four lines you have in there
+config MTD_NAND_OMAP_BCH_BUILD
+ tristate
+ depends on MTD_NAND_OMAP2
+ default m if MTD_NAND_OMAP2=m && MTD_NAND_OMAP_BCH
+ default y if MTD_NAND_OMAP2=y && MTD_NAND_OMAP_BCH
should be entirely equivalent to the two lines I wrote above, so my version
is just a readability change, functionally they both are correct as far as
I can tell.
Arnd