On 21.10.2014 15:52, Alim Akhtar wrote:
quoted
+&mmc_0 {
+ status = "okay";
+ num-slots = <1>;
+ broken-cd;
+ caps2-mmc-hs200-1_8v;
Please use mmc_hs200-1_8v instead.
I guess you mean "mmc-hs200-1_8v" (with a hyphen between mmc and hs200).
quoted
+ supports-highspeed;
As per synopsys-dw-mshc DT binding documentation, supports-highspeed
property is deprecated, so please use common DT binding for this,
which is "cap-mmc-highspeed".
quoted
+ non-removable;
+ card-detect-delay = <200>;
+ clock-frequency = <800000000>;
+ samsung,dw-mshc-ciu-div = <3>;
+ samsung,dw-mshc-sdr-timing = <0 4>;
+ samsung,dw-mshc-ddr-timing = <0 2>;
+ pinctrl-names = "default";
+ pinctrl-0 = <&sd0_clk &sd0_cmd &sd0_qrdy &sd0_bus1 &sd0_bus4 &sd0_bus8>;
+ bus-width = <8>;
+};
+
+&mmc_2 {
+ status = "okay";
+ num-slots = <1>;
+ supports-highspeed;
Here also common DT binding please "cap-sd-highspeed"
Above you suggest "cap-mmc-highspeed" to replace the same deprecated
property, but here "cap-sd-highspeed". What is the rationale behind
using only one particular new property and not both for both controllers?
Best regards,
Tomasz