[PATCH v6 5/6] sched: replace capacity_factor by usage
From: vincent.guittot@linaro.org (Vincent Guittot)
Date: 2014-09-26 12:40:04
Also in:
lkml
From: vincent.guittot@linaro.org (Vincent Guittot)
Date: 2014-09-26 12:40:04
Also in:
lkml
On 25 September 2014 21:19, Dietmar Eggemann [off-list ref] wrote:
On 25/09/14 09:35, Vincent Guittot wrote:
[snip]
quoted
quoted
In case sgs->group_type is group_overloaded you could set sgs->group_out_of_capacity to 1 without calling group_is_overloaded again.I prefer to keep sgs->group_out_of_capacity = group_is_overloaded(sgs, env) and use it in group_classify in case of future changes in the classification orderOk, but than group_is_overloaded is called twice at the end of update_sg_lb_stats with exactly the same result. Looks weird in my traces.
sorry i don't catch your point. group_is_overloaded() is called once for group_out_of_capacity which is then used in group_classify so it should be called only once
quoted
[...]