[PATCH 1/2] ARM: shmobile: r8a7779 dtsi: Correct #address-cells/#size-cells for clocks
From: geert@linux-m68k.org (Geert Uytterhoeven)
Date: 2014-05-23 06:55:23
Also in:
linux-devicetree, linux-sh
Hi Laurent, On Fri, May 23, 2014 at 1:08 AM, Laurent Pinchart [off-list ref] wrote:
quoted
- cpg_clocks: cpg_clocks at 0xe6150000 { + cpg_clocks: cpg_clocks at 0xffc80000 {No need for a 0x prefix.
Thanks, missed that one.
quoted
compatible = "renesas,r8a7779-cpg-clocks"; - reg = <0 0xffc80000 0 0x30>; + reg = <0xffc80000 0x30>;This looks good.quoted
clocks = <&extal_clk>; #clock-cells = <1>; clock-output-names = "plla", "z", "zs", "s",@@ -342,10 +342,10 @@ }; /* Gate clocks */ - mstp0_clks: mstp0_clks { + mstp0_clks: mstp0_clks at ffc80030 {The @address is only mandatory to differentiate between nodes with identical names. As the node name is supposed to describe the device function, maybe we could rename it to clocks at ffc80030 ? As you modify the CPG node address above it might make sense to rename it to clocks at ffc80000 too.
Sounds good!
I'm not advocating for a rename now, but as your patch touches the names, I think they should be fixed properly (or not at all).
In hindsight, I should have separated the fix and the "obvious small things",
as the latter are subject to bike-shedding ;-)
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert at linux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds