Thread (1 message) 1 message, 1 author, 2013-11-06
DORMANTno replies

[PATCH 0/2] ARM: mvebu: fix DT def. of PCIe units for mv78230 and mv78260

From: Arnaud Ebalard <hidden>
Date: 2013-11-06 21:32:57

Hi Jason,

Jason Cooper [off-list ref] writes:
On Wed, Nov 06, 2013 at 11:37:24AM -0700, Jason Gunthorpe wrote:
...
quoted
This PCI stuff would be 100% more readable with some macros ..

#define PCI_REG_BDF(bus,device,function) (....)
#define PCI_MEM_BAR_BDF(bus,device,function,bar) \
   (0x82000000 | PCI_REG_BDF(bus,device,function) + bar*XX) 0)

So that:
 reg = <PCI_REG_BDF(0,1,0) 0 0>
 assigned-addresses = <PCI_MEM_BAR_BDF(0,1,0,0)  0x40000  0 0x2000>
Do I smell a patch brewing?  :)

Arnaud, would you like to take a crack at it?
My understanding of the topic being in the end limited to what I learnt
from recent discussions, I'll pass on that one but I'll be happy to test
on a mv78230.

Cheers,

a+
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help