Thread (12 messages) 12 messages, 2 authors, 2013-10-31

[PATCH 2/3] dma: edma: Add support for Cyclic DMA

From: Vinod Koul <hidden>
Date: 2013-10-24 17:33:14
Also in: alsa-devel, linux-omap, lkml

On Tue, Oct 22, 2013 at 10:30:43AM -0500, Joel Fernandes wrote:
On 10/21/2013 01:53 AM, Vinod Koul wrote:
quoted
On Mon, Sep 23, 2013 at 06:05:14PM -0500, Joel Fernandes wrote:
quoted
+	nr_periods = (buf_len / period_len) + 1;
?

consider the case of buf = period_len, above makes nr_period = 2.

Or buf len 100, period len 50, makes nr_period = 3

Both doesnt seem right to me?
I guess that variable name is misleading.

nr_periods is actually the total no.of slots needed to process the request. Its
value is 1 greater than the total number of periods.
Okay sounds good to me. I tried applying below but looks like it fails as I have
already applied, 1 & 3. Can you pls rebase this resend

--
~Vinod
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help