Thread (37 messages) 37 messages, 6 authors, 2013-08-09

[PATCH v2 2/3] ARM: dt: t114 dalmore: add dt entry for nct1008

From: Wei Ni <hidden>
Date: 2013-08-09 06:16:22
Also in: linux-tegra, lkml

On 08/09/2013 05:33 AM, Guenter Roeck wrote:
On 08/08/2013 01:40 PM, Stephen Warren wrote:
quoted
On 08/08/2013 02:36 PM, Sergei Shtylyov wrote:
quoted
Hello.

On 08/08/2013 10:56 AM, Wei Ni wrote:
quoted
Enable thermal sensor nct1008 for t114 dalmore.
quoted
Signed-off-by: Wei Ni <redacted>
---
   arch/arm/boot/dts/tegra114-dalmore.dts |   10 +++++++++-
   1 file changed, 9 insertions(+), 1 deletion(-)
quoted
diff --git a/arch/arm/boot/dts/tegra114-dalmore.dts
b/arch/arm/boot/dts/tegra114-dalmore.dts
index b5a42f0..9d4d2b2 100644
--- a/arch/arm/boot/dts/tegra114-dalmore.dts
+++ b/arch/arm/boot/dts/tegra114-dalmore.dts
@@ -738,6 +738,14 @@
               realtek,ldo1-en-gpios =
                   <&gpio TEGRA_GPIO(V, 3) GPIO_ACTIVE_HIGH>;
           };
+
+        nct1008 {
    ePAPR [1] says: "the name of a node should be somewhat generic,
reflecting the function of the device and not its precise programming
model". So I suggest "thermal"
True, although there's quite some precedent for node-names being the
chip name for external chips in existing DTs. If we change this node
name, I'd like to see a patch that makes all the other "nct1008" nodes
match the new name...
On the other side, one should not use a bad example as an argument or excuse
to make the same mistake again (though I keep hearing it all the time ... ).
I for my part tend to use something like temp-sensor or temp-sensor at 1c.
Advantage of that kind of node name is that it auto-describes the node.
Ok, so I will set the node name as "temp-sensor"
And I will send out patches to change all other "nct1008" nodes.
Guenter
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help