Thread (1 message) 1 message, 1 author, 2013-02-20
DORMANTno replies REVIEWED: 1 (0M)

1 review trailer.

[PATCH 2/3] ARM: dts: imx: replace magic number with pin function name

From: Dong Aisheng <hidden>
Date: 2013-02-20 09:30:25

On 20 February 2013 15:08, Shawn Guo [off-list ref] wrote:
This turns the imx pin function number defined by binding document
into #define constants in header which can be used in dts and handled
by pre-processor to improve the readability of device tree sources.

Signed-off-by: Shawn Guo <redacted>
.........
                                usdhc4 {
                                        pinctrl_usdhc4_1: usdhc4grp-1 {
                                                fsl,pins = <
-                                                       1386 0x17059    /* MX6Q_PAD_SD4_CMD__USDHC4_CMD */
-                                                       1392 0x10059    /* MX6Q_PAD_SD4_CLK__USDHC4_CLK */
-                                                       1462 0x17059    /* MX6Q_PAD_SD4_DAT0__USDHC4_DAT0 */
-                                                       1470 0x17059    /* MX6Q_PAD_SD4_DAT1__USDHC4_DAT1 */
-                                                       1478 0x17059    /* MX6Q_PAD_SD4_DAT2__USDHC4_DAT2 */
-                                                       1486 0x17059    /* MX6Q_PAD_SD4_DAT3__USDHC4_DAT3 */
-                                                       1493 0x17059    /* MX6Q_PAD_SD4_DAT4__USDHC4_DAT4 */
-                                                       1501 0x17059    /* MX6Q_PAD_SD4_DAT5__USDHC4_DAT5 */
-                                                       1509 0x17059    /* MX6Q_PAD_SD4_DAT6__USDHC4_DAT6 */
-                                                       1517 0x17059    /* MX6Q_PAD_SD4_DAT7__USDHC4_DAT7 */
+                                                       MX6Q_PAD_SD4_CMD__USDHC4_CMD   0x17059
+                                                       MX6Q_PAD_SD4_CLK__USDHC4_CLK   0x10059
+                                                       MX6Q_PAD_SD4_DAT0__USDHC4_DAT0 0x17059
+                                                       MX6Q_PAD_SD4_DAT1__USDHC4_DAT1 0x17059
+                                                       MX6Q_PAD_SD4_DAT2__USDHC4_DAT2 0x17059
+                                                       MX6Q_PAD_SD4_DAT3__USDHC4_DAT3 0x17059
+                                                       MX6Q_PAD_SD4_DAT4__USDHC4_DAT4 0x17059
+                                                       MX6Q_PAD_SD4_DAT5__USDHC4_DAT5 0x17059
+                                                       MX6Q_PAD_SD4_DAT6__USDHC4_DAT6 0x17059
+                                                       MX6Q_PAD_SD4_DAT7__USDHC4_DAT7 0x17059
IMO we could also replace the config value with a macro.
You could either do it in this patch or another separate patch.
So,
Acked-by: Dong Aisheng <redacted>

Regards
Dong Aisheng
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help