Thread (14 messages) 14 messages, 4 authors, 2012-09-17
STALE5036d

[PATCH 2/2] ARM: dts: exynos4: allow i2c0 bus to be configured using pinctrl interface

From: Thomas Abraham <hidden>
Date: 2012-09-06 11:14:54
Also in: linux-i2c, linux-samsung-soc

On 6 September 2012 15:43, Tomasz Figa [off-list ref] wrote:
Hi Thomas,

On Thursday 06 of September 2012 14:53:01 Thomas Abraham wrote:
quoted
              compatible = "samsung,s3c2440-i2c";
              reg = <0x13860000 0x100>;
              interrupts = <0 58 0>;
+             pinctrl-names = "default";
+             pinctrl-0 = <&i2c0_bus>;
If pinctrl-names property is omitted then the state index is used as a name
(e.g. pinctrl-0 would be named "0"). Maybe it would be better to use this
approach (with respective adjustment in first patch)? What do you think?
I tend to prefer to name the states because it is easier to
cross-reference code and dts files. i2c was a simple one, but for mmc
controllers, there will 1-bit state, 4-bit state and 8-bit state, and
it will be nicer to name then accordingly. So I prefer to use names
but if there is wider consensus on not using names, we can drop names.

Thanks,
Thomas.
Best regards,
--
Tomasz Figa
Samsung Poland R&D Center
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help