[PATCH 13/14] arm: at91: dt: at91sam9 add nand pinctrl support
From: Jean-Christophe PLAGNIOL-VILLARD <hidden>
Date: 2012-08-16 17:38:44
On 17:19 Thu 16 Aug , Richard Genoud wrote:
2012/8/15 Linus Walleij [off-list ref]:quoted
On Fri, Aug 10, 2012 at 3:02 PM, Jean-Christophe PLAGNIOL-VILLARD [off-list ref] wrote:quoted
Cc: Linus Walleij <redacted> Cc: Nicolas Ferre <redacted> Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <redacted>(...)quoted
+ nand { + pinctrl_nand: nand-0 { + atmel,pins = + <2 13 0x0 0x1 /* PC13 gpio RDY pin pull_up */ + 2 14 0x0 0x1>; /* PC14 gpio enable pin pull_up */ + }; + };Again magic hex I don't understand so skipping this patch -> Nicolas.Maybe it will be more readable if we use something like : atmel,pull-up; atmel,multidrive; atmel,mux="GPIO" atmel,mux="A" ... just my 2 cents...
no too much data and too much node as you will need a node per pin which we tyr to avoid Best Regards, J.