Thread (1 message) 1 message, 1 author, 2012-08-08

[rtc-linux] [PATCH 8/8] ARM: vt8500: gpio: Devicetree support for arch-vt8500

From: Tony Prisk <hidden>
Date: 2012-08-08 19:46:54
Also in: linux-devicetree, linux-serial

This needs to be named something intuitive like "vt8500_gpio_bank_regoffsets"
Some kerneldoc intsead of the opaque comment above will also improve
readability a lot:
/**
 * struct vt8500_gpio_bank_regoffsets
 * @en: offset to enable register in the bank
 * ...
Changes made as requested.

My feeling however is that the "vt8500_chip->regoff" is wrong, which
would mean only the first bank works. The code adds the same offsets
per bank once more that it sets in this bank table.
       Arnd
Oh.. Thanks for picking that up Arnd. You are absolutely correct. I have removed
the references for ->regoff. Left over from old code.

Regards

Tony Prisk
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help