[PATCH V3 3/5] clk: mmp: add clock definition for pxa910

From
Arnd Bergmann <arnd@arndb.de>
Date
2012-08-16 08:09:44
Also in
lkml
Reply to
Chao Xie, 2012-08-16
On Thursday 16 August 2012, Chao Xie wrote:
quoted
quoted
+     clocks[uart0_mux] =
+         clk_register_mux(NULL, "uart0_mux", uart_parent,
+                          ARRAY_SIZE(uart_parent), CLK_SET_RATE_PARENT,
+                          apbc_base + APBC_UART0, 4, 3, 0, &clk_lock);
i can change remove the clocks array, but even make the sentence
shorter, most of them still can not fit in one line.
Don't worry too much about the line length or a particular style. This is
all about readability, and the style you use above may conform to some
written style guide, but it's not the most readable one. If you reformat
it to 

	clk = clk_register_mux(NULL, "uart0_mux", uart_parent, ARRAY_SIZE(uart_parent), CLK_SET_RATE_PARENT, apbc_base + APBC_UART0, 4, 3, 0, &clk_lock);

or

	clk = clk_register_mux(NULL, "uart0_mux", uart_parent, ARRAY_SIZE(uart_parent),
		CLK_SET_RATE_PARENT, apbc_base + APBC_UART0, 4, 3, 0, &clk_lock);

or

	clk = clk_register_mux(NULL, "uart0_mux", uart_parent,
		 ARRAY_SIZE(uart_parent), CLK_SET_RATE_PARENT,
		 apbc_base + APBC_UART0, 4, 3, 0, &clk_lock);

I still find that more readable.

	Arnd
Thread (10 messages) 10 messages, 2 authors, 2012-08-16
Keyboard shortcuts
hback out one level
jnext message in thread / next series-diff position
kprevious message in thread / previous series-diff position
ldrill in
Escclose help / fold thread tree
?toggle this help