Thread (30 messages) flat view 30 messages, 4 authors, 2012-09-19

[PATCHv4 4/8] ARM: OMAP3: add manual control for mpu / core pwrdm usecounting

From: Rajendra Nayak <hidden>
Date: 2012-07-16 10:30:54
Also in: linux-omap

On Friday 13 July 2012 07:49 PM, Tero Kristo wrote:
quoted hunk ↗ jump to hunk
mpu / core powerdomain usecounts are now statically increased
by 1 during MPU activity. This allows the domains to reflect
actual usage, and will allow the usecount to reach 0 just before
all CPUs are ready to idle. Proper powerdomain usecounts are
propageted to voltagedomain level also, and will allow vc
callbacks to be triggered at right point of time.

Signed-off-by: Tero Kristo<redacted>
Cc: Paul Walmsley<paul@pwsan.com>
Cc: Kevin Hilman<redacted>
---
  arch/arm/mach-omap2/pm34xx.c      |    3 ++
  arch/arm/mach-omap2/pm44xx.c      |    3 ++
  arch/arm/mach-omap2/powerdomain.c |   64 +++++++++++++++++++++++++++++++++++++
  arch/arm/mach-omap2/powerdomain.h |    3 ++
  4 files changed, 73 insertions(+), 0 deletions(-)
diff --git a/arch/arm/mach-omap2/pm34xx.c b/arch/arm/mach-omap2/pm34xx.c
index 3a595e8..7c7b173 100644
--- a/arch/arm/mach-omap2/pm34xx.c
+++ b/arch/arm/mach-omap2/pm34xx.c
@@ -758,6 +758,9 @@ int __init omap3_pm_init(void)
  	omap_pm_suspend = omap3_pm_suspend;
  #endif

+	/* Notify pwrdm usecounters about active CPU */
+	pwrdm_cpu_wakeup();
+
These internally increment/decrement usecount for MPU and CORE
but the name pwrdm_cpu_wakeup/idle seems somewhat misleading.
But I don't know either what would be a better name, so..

Reviewed-by: Rajendra Nayak <redacted>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help