Thread (24 messages) flat view 24 messages, 5 authors, 2012-06-15
STALE5212d

[PATCH v3 1/9] clocksource: time-armada-370-xp: Marvell Armada 370/XP SoC timer driver

From: nico@fluxnic.net (Nicolas Pitre)
Date: 2012-06-15 13:14:34

On Fri, 15 Jun 2012, Andrew Lunn wrote:
quoted
About calling it orion, it should be mvebu I think.
I guess that's another discussion. All current device drivers, except
Ethernet and I2C are called orion. Orion currently means anything
shared by orion5x, kirkwood, dove, mv78xx0. It seems unlikely we are
going to rename all the device drivers. So calling it mvebu will just
add to the confusion, not reduce the confusion. I personally would
say, anything inside mach-mvebu which is shared by multiple SoCs, can
be prefixed mvebu_. However, anything outside mach-mvebu should remain
orion_.
Well, a halfway cleanup is potentially even more confusing than a 
complete one.  So it would be best to also rename "orion" to "mvebu" for 
stuff outside of mach-mvebu.

Your point holds for things which are shared beyond the mvebu SOCs 
though, such as mv643 or sata_mv.


Nicolas
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help