Thread (1 message) 1 message, 1 author, 2012-05-22

[PATCH v4 1/7] ARM: davinci, intc: Add irq domain support

From: Sergei Shtylyov <hidden>
Date: 2012-05-22 15:51:24
Also in: linux-devicetree

On 05/22/2012 05:55 PM, Heiko Schocher wrote:
Signed-off-by: Heiko Schocher<redacted>
Cc: davinci-linux-open-source at linux.davincidsp.com
Cc: linux-arm-kernel at lists.infradead.org
Cc: devicetree-discuss at lists.ozlabs.org
Cc: Grant Likely<redacted>
Cc: Sekhar Nori<redacted>
Cc: Wolfgang Denk<redacted>
Cc: Sergei Shtylyov<redacted>
    In the patch subject, you'd better specify cp_intc, to avoid any confusion. 
Same comment for the next patch...
quoted hunk
diff --git a/arch/arm/mach-davinci/cp_intc.c b/arch/arm/mach-davinci/cp_intc.c
index f83152d..bb52807 100644
--- a/arch/arm/mach-davinci/cp_intc.c
+++ b/arch/arm/mach-davinci/cp_intc.c
[...]
quoted hunk
@@ -99,18 +101,37 @@ static struct irq_chip cp_intc_irq_chip = {
[...]
+int __init __cp_intc_init(struct device_node *node)
+{
+	u32 num_irq		= davinci_soc_info.intc_irq_num;
  	u8 *irq_prio		= davinci_soc_info.intc_irq_prios;
  	u32 *host_map		= davinci_soc_info.intc_host_map;
  	unsigned num_reg	= BITS_TO_LONGS(num_irq);
-	int i;
+	int i, irq_base;

  	davinci_intc_type = DAVINCI_INTC_TYPE_CP_INTC;
  	davinci_intc_base = ioremap(davinci_soc_info.intc_base, SZ_8K);
+
    Empty line not needed.
  	if (WARN_ON(!davinci_intc_base))
[...]
quoted hunk
@@ -165,13 +186,28 @@ void __init cp_intc_init(void)
  		for (i = 0; host_map[i] != -1; i++)
  			cp_intc_write(host_map[i], CP_INTC_HOST_MAP(i));

-	/* Set up genirq dispatching for cp_intc */
-	for (i = 0; i<  num_irq; i++) {
-		irq_set_chip(i,&cp_intc_irq_chip);
-		set_irq_flags(i, IRQF_VALID | IRQF_PROBE);
-		irq_set_handler(i, handle_edge_irq);
+	irq_base = irq_alloc_descs(-1, 0, num_irq, 0);
+	if (irq_base < 0) {
+		pr_warn("Couldn't allocate IRQ numbers\n");
+		irq_base = 0;
+	}
+
+	/* create a legacy host */
+	cp_intc_domain = irq_domain_add_legacy(node, num_irq,
+					irq_base, 0,&cp_intc_host_ops, NULL);
+
+	if (cp_intc_domain == NULL) {
    'if (!cp_int_domain)' please -- to keep the style consistent.
+		pr_err("CP INTC: failed to allocate irq host!\n");
   s/CP_INTC/cp_intc/

WBR, Sergei
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help