[PATCH 1/2] imx: Add save/restore functions for UART control regs
From: s.hauer@pengutronix.de (Sascha Hauer)
Date: 2011-12-19 10:10:23
Also in:
linux-serial
On Mon, Dec 19, 2011 at 07:49:56AM +0100, Dirk Behme wrote:
On 19.12.2011 04:49, Shawn Guo wrote:quoted
On Sun, Dec 18, 2011 at 06:34:14PM +0100, Dirk Behme wrote:quoted
Factor out the uart save/restore functionality instead of having the same code several times in the driver. Signed-off-by: Dirk Behme<redacted> CC: Saleem Abdulrasool<redacted> CC: Sascha Hauer<s.hauer@pengutronix.de> CC: Fabio Estevam<festevam@gmail.com> CC: Uwe Kleine-K?nig<redacted> CC: linux-serial at vger.kernel.org --- drivers/tty/serial/imx.c | 38 +++++++++++++++++++++++++++++++------- 1 files changed, 31 insertions(+), 7 deletions(-)diff --git a/drivers/tty/serial/imx.c b/drivers/tty/serial/imx.c index 163fc90..6a01c2a 100644 --- a/drivers/tty/serial/imx.c +++ b/drivers/tty/serial/imx.c@@ -260,6 +260,31 @@ static inline int is_imx21_uart(struct imx_port *sport) } /* + * Save and restore functions for UCR1, UCR2 and UCR3 registers + */ +static void imx_console_mode(struct uart_port *port,Function name imx_console_mode seems not like a couple with imx_console_restore. And I guess something like imx_port_ucrs_save[restore] would be better?quoted
+ unsigned int *ucr1, + unsigned int *ucr2, + unsigned int *ucr3)Can we define something like 'struct imx_port_ucrs' to contains these?Yes, we could have different function names above and use a struct. I implemented what Sascha asked for in http://www.spinics.net/lists/arm-kernel/msg144960.html though: -- Sascha wrote: -- I'm thinking about: imx_console_mode(struct uart_port *port, u32 *ucr1, u32 *ucr2, u32 *ucr2); imx_console_restore(struct uart_port *port, u32 ucr1, u32 ucr2, u32 ucr3); -- Sascha end -- It seems Shawn proposes imx_port_ucrs_save(struct uart_port *port, struct *imx_port_ucrs); imx_port_ucrs_restore(struct uart_port *port, struct *imx_port_ucrs); (?) Sascha, Shawn: Could you agree on what we should use?
I think save/restore are better names. Maybe I thought about a function which saves the current values *and* sets ucrx to other values. In that case imx_port_ucrs_save() would be the wrong name.
Once you agreed, I will send an update of both two patches.
+1 for save/restore Sascha -- Pengutronix e.K. | | Industrial Linux Solutions | http://www.pengutronix.de/ | Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 | Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |