Thread (11 messages) flat view 11 messages, 4 authors, 2011-10-05
STALE5458d

[PATCH V2 2/2] ARM: SAMSUNG: Cleanup resources by using macro

From: Kukjin Kim <hidden>
Date: 2011-10-05 01:17:16
Also in: linux-samsung-soc

Kyungmin Park wrote:
On Wed, Oct 5, 2011 at 12:26 AM, Arnd Bergmann [off-list ref] wrote:
quoted
On Tuesday 04 October 2011, Kukjin Kim wrote:
quoted
quoted
I think the string concatenation really just obfuscates the code, and
it does not actually save much at all. When you replace

+ ? ? ? [0] = SAMSUNG_RES_MEM(S3C, WDT, SZ_1K),
+ ? ? ? [1] = SAMSUNG_RES_IRQ(WDT),

with

+ ? ? ? [0] = DEFINE_RES_MEM(S3C_PA_WDT, SZ_1K),
+ ? ? ? [1] = DEFINE_RES_IRQ(IRQ_WDT),

you need practically no extra space, but you gain the advantages that

* Someone using grep for DEFINE_RES_MEM finds all memory resources
without
quoted
quoted
quoted
? having to look up what your macros do an where they are used.
* Someone using grep to look for S3C_PA_WDT finds the place where it
is
quoted
quoted
used.
quoted
* Someone reading the resource definition immediately knows what the
? macro does if familiar with other platforms using that macro.
Yes, right. But I'm preparing to reduce the 'soc' part to consolidate
some
quoted
quoted
duplicated resources and platform data after this and the new
SAMSUNG_RES
quoted
quoted
macro will be used.
There are tools for source browsing e.g., ctags, cscope, grep, git
grep and so on.
If you create new SAMSUNG_RES, these tools can't find macro and
symbols properly.

Please use the existing macros for own purpose.
OK, it makes sense to me.

Thanks.

Best regards,
Kgene.
--
Kukjin Kim [off-list ref], Senior Engineer,
SW Solution Development Team, Samsung Electronics Co., Ltd.
Thank you,
Kyungmin Park
quoted
Hmm, can't you instead change the names of these constants to be
always the same? That would let you use the regular DEFINE_RES_*
definitions without having to introduce your own.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help