Jean Pihet [off-list ref] writes:
Kevin,
On Mon, Aug 29, 2011 at 7:35 PM, Kevin Hilman [off-list ref] wrote:
quoted
As part of the voltage layer cleanup, split out VC specific code into
a dedicated VC layer. ?This patch primarily just moves VC code from
voltage.c into vc.c, and adds prototypes to vc.h.
No functional changes.
For readability, each function was given a local 'vc' pointer:
? ?struct omap_vc_instance_data *vc = voltdm->vdd->vc_data;
and a global replace of s/vdd->vc_data/vc/ was done.
Also vc_init was renamed to vc_init_channel to reflect that this is
per-VC channel initializtion.
Signed-off-by: Kevin Hilman <redacted>
---
?arch/arm/mach-omap2/Makefile ?| ? ?2 +-
?arch/arm/mach-omap2/vc.c ? ? ?| ?276 +++++++++++++++++++++++++++++++++++++++++
?arch/arm/mach-omap2/vc.h ? ? ?| ? 12 ++
?arch/arm/mach-omap2/voltage.c | ?264 +--------------------------------------
?4 files changed, 293 insertions(+), 261 deletions(-)
?create mode 100644 arch/arm/mach-omap2/vc.c
...
quoted
diff --git a/arch/arm/mach-omap2/vc.c b/arch/arm/mach-omap2/vc.c
new file mode 100644
index 0000000..98f5a4b
--- /dev/null
+++ b/arch/arm/mach-omap2/vc.c
The copyright notice is missing.
oops, will add.
Thanks,
Kevin