On Mon, Aug 29, 2011 at 4:36 PM, Wolfram Sang [off-list ref] wrote:
On Mon, Aug 29, 2011 at 03:18:55PM +0800, Richard Zhu wrote:
quoted
On imx53 AHCI, soft reset fails with IPMS set when PMP
is enabled but SATA HDD/ODD is connected to SATA port,
do soft reset again to port 0.
So the 'ahci_pmp_retry_srst_ops' is required when imx53
ahci is present.
Signed-off-by: Richard Zhu <redacted>
---
?drivers/ata/ahci_platform.c | ? 44 +++++++++++++++++++++++++++++++++++++-----
?1 files changed, 38 insertions(+), 6 deletions(-)
diff --git a/drivers/ata/ahci_platform.c b/drivers/ata/ahci_platform.c
index 6fef1fa..f32c91e 100644
--- a/drivers/ata/ahci_platform.c
+++ b/drivers/ata/ahci_platform.c
?#include <linux/ahci_platform.h>
?#include "ahci.h"
+enum ahci_type {
+ ? ? AHCI, ? ? ? ? ? /* standard platform ahci */
+ ? ? IMX53_AHCI, ? ? /* ahci on i.mx53 */
How about making all the IMX*-naming more generic because other SoC might need
this somewhen, too?