[RFC 0/8] Introducing a generic AMP/IPC framework
From: arnd@arndb.de (Arnd Bergmann)
Date: 2011-06-22 13:05:48
Also in:
linux-omap, lkml
From: arnd@arndb.de (Arnd Bergmann)
Date: 2011-06-22 13:05:48
Also in:
linux-omap, lkml
On Wednesday 22 June 2011, Ohad Ben-Cohen wrote:
quoted
One point I noticed is the use of debugfs, which you should probably replace at some point with a stable API, e.g. your own debugfs-like file system, but there is no hurry to do that now.debugfs is only being used to expose debugging info (namely the power state of the remote processor and its trace log messages), which is mostly useful for developers trying to understand what went wrong. It seems like debugfs fits quite nicely here (e.g. it's perfectly fine if this is completely compiled out on production systems), but sure, we can always revisit this later too.
Ok, I see. In that case I agree that using debugfs is fine, but I would recommend trying to use fewer macros and just open-coding the file operations for better readability.
quoted
Unfortunately require __packed. It would be better to sort the members differently so that each member is naturally aligned in order to avoid the need for padding or __packed attributesDefinitely. __packed is being used just to be on the safe side; we didn't intend to introduce unnatural alignment intentionally. will be fixed.
Ok. Arnd