On Friday 03 June 2011 11:54:14 Fabio Estevam wrote:
On Thu, Jun 2, 2011 at 12:33 AM, Shawn Guo [off-list ref] wrote:
...
quoted
+void __init imx1_soc_init(void)
+{
+ mxc_register_gpio(0, MX1_GPIO1_BASE_ADDR, SZ_4K, MX1_GPIO_INT_PORTA, 0);
+ mxc_register_gpio(1, MX1_GPIO2_BASE_ADDR, SZ_4K, MX1_GPIO_INT_PORTB, 0);
+ mxc_register_gpio(2, MX1_GPIO3_BASE_ADDR, SZ_4K, MX1_GPIO_INT_PORTC, 0);
+ mxc_register_gpio(3, MX1_GPIO4_BASE_ADDR, SZ_4K, MX1_GPIO_INT_PORTD, 0);
By just reading the function names like "imx1_soc_init" we have really
no clue of what it actually does.
"soc_init" is too vague IMHO. Could?t you change the names to
something like "imx1_gpio_init" or "imx1_gpio_register".
It would be nice at least are dealing with gpio.
Olof and I asked Shawn to do it specifically this way, so we have a place
where more SOC specific initialization can be added without having to
change every single board file.
Arnd